What’s Vulnerable › Vulnerabilities
CVE-2025-66388: Apache Airflow: Secrets in rendered templates not redacted properly and exposed in the UI
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-15 · updated 2026-10-07
- Weakness: CWE-201
Description
A vulnerability in Apache Airflow allowed authenticated UI users to view secret values in rendered templates due to secrets not being properly redacted, potentially exposing secrets to users without the appropriate authorization. Users are recommended to upgrade to version 3.1.4, which fixes this issue.
Affected products
- Apache Airflow: from 3.1.0 before 3.1.4 — fixed in 3.1.4
How to fix
Upgrade to a fixed version: Apache Airflow 3.1.4. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/58772
- https://lists.apache.org/thread/mv9hzsx8grjf7gdlkxwppnpbtogtls2g
- http://www.openwall.com/lists/oss-security/2025/12/12/1
Get alerted when CVE-2025-66388 or the next vulnerability affects your stack