What’s Vulnerable › Vulnerabilities
CVE-2025-66399: SNMP Command Injection leads to RCE in Cacti
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-02 · updated 2026-10-18
- Weakness: CWE-77
Description
Cacti is an open source performance and fault management framework. Prior to 1.2.29, there is an input-validation flaw in the SNMP device configuration functionality. An authenticated Cacti user can supply crafted SNMP community strings containing control characters (including newlines) that are accepted, stored verbatim in the database, and later embedded into backend SNMP operations. In environments where downstream SNMP tooling or wrappers interpret newline-separated tokens as command boundaries, this can lead to unintended command execution with the privileges of the Cacti process. This vulnerability is fixed in 1.2.29.
Affected products
- cacti: before 1.2.29 — fixed in 1.2.29
How to fix
Upgrade to a fixed version: cacti 1.2.29. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-66399 or the next vulnerability affects your stack