What’s Vulnerable › Vulnerabilities
CVE-2025-66404: mcp-server-kubernetes potential security issue in exec_in_pod tool
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-03 · updated 2026-06-17
- Weakness: CWE-77
Description
MCP Server Kubernetes is an MCP Server that can connect to a Kubernetes cluster and manage it. Prior to 2.9.8, there is a security issue exists in the exec_in_pod tool of the mcp-server-kubernetes MCP Server. The tool accepts user-provided commands in both array and string formats. When a string format is provided, it is passed directly to shell interpretation (sh -c) without input validation, allowing shell metacharacters to be interpreted. This vulnerability can be exploited through direct command injection or indirect prompt injection attacks, where AI agents may execute commands without explicit user intent. This vulnerability is fixed in 2.9.8.
Affected products
- Flux159 mcp-server-kubernetes: before 2.9.8 — fixed in 2.9.8
How to fix
Upgrade to a fixed version: Flux159 mcp-server-kubernetes 2.9.8. Check the vendor advisory for mitigations.
References
- https://github.com/Flux159/mcp-server-kubernetes/commit/d091107ff92d9ffad1b3c295092f142d6578c48b
- https://github.com/Flux159/mcp-server-kubernetes/security/advisories/GHSA-wvxp-jp4w-w8wg
- https://github.com/Flux159/mcp-server-kubernetes/security/advisories/GHSA-wvxp-jp4w-w8wg
Get alerted when CVE-2025-66404 or the next vulnerability affects your stack