What’s Vulnerable › Vulnerabilities
CVE-2025-66419: MaxKB vulnerable to privilege escalation through sandbox bypass
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-11 · updated 2026-10-07
- Weakness: CWE-362
Description
MaxKB is an open-source AI assistant for enterprise. In versions 2.3.1 and below, the tool module allows an attacker to escape the sandbox environment and escalate privileges under certain concurrent conditions. This issue is fixed in version 2.4.0.
Affected products
- 1Panel-dev MaxKB: before 2.4.0 — fixed in 2.4.0
How to fix
Upgrade to a fixed version: 1Panel-dev MaxKB 2.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/1Panel-dev/MaxKB/commit/f8ada9a110c4dbef8c3c2636c78847ecd621ece7
- https://github.com/1Panel-dev/MaxKB/releases/tag/v2.4.0
- https://github.com/1Panel-dev/MaxKB/security/advisories/GHSA-f9qm-2pxq-fx6c
Get alerted when CVE-2025-66419 or the next vulnerability affects your stack