What’s Vulnerable › Vulnerabilities
CVE-2025-66430
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-12 · updated 2026-10-14
- Weakness: CWE-284
Description
Plesk 18.0 has Incorrect Access Control.
Affected products
- Plesk: from 18.0.70 before 18.0.73.5; from 18.0.74 before 18.0.74.2 — fixed in 18.0.73.5, 18.0.74.2
How to fix
Upgrade to a fixed version: Plesk 18.0.73.5, 18.0.74.2. Check the vendor advisory for mitigations.
References
- https://docs.plesk.com/release-notes/obsidian/whats-new/
- https://support.plesk.com/hc/en-us/articles/36261922405015--CVE-2025-66430-Security-vulnerability-in-Password-Protected-Directories-allows-Plesk-users-to-gain-root-level-access-to-a-Plesk-server
Get alerted when CVE-2025-66430 or the next vulnerability affects your stack