What’s Vulnerable › Vulnerabilities

CVE-2025-66431

Description

WebPros Plesk before 18.0.73.5 and 18.0.74 before 18.0.74.2 on Linux allows remote authenticated users to execute arbitrary code as root via domain creation. The attacker needs "Create and manage sites" with "Domains management" and "Subdomains management."

Affected products

How to fix

Upgrade to a fixed version: Plesk 18.0.73.5, 18.0.74.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-66431 or the next vulnerability affects your stack