What’s Vulnerable › Vulnerabilities
CVE-2025-66448: vLLM vulnerable to remote code execution via transformers_utils/get_config
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-01 · updated 2026-10-18
- Weakness: CWE-94
Description
vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.11.1, vllm has a critical remote code execution vector in a config class named Nemotron_Nano_VL_Config. When vllm loads a model config that contains an auto_map entry, the config class resolves that mapping with get_class_from_dynamic_module(...) and immediately instantiates the returned class. This fetches and executes Python from the remote repository referenced in the auto_map string. Crucially, this happens even when the caller explicitly sets trust_remote_code=False in vllm.transformers_utils.config.get_config. In practice, an attacker can publish a benign-looking frontend repo whose config.json points via auto_map to a separate malicious backend repo; loading the frontend will silently run the backend’s code on the victim host. This vulnerability is fixed in 0.11.1.
Affected products
- vllm-project vllm: before 0.11.1 — fixed in 0.11.1
How to fix
Upgrade to a fixed version: vllm-project vllm 0.11.1. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/commit/ffb08379d8870a1a81ba82b72797f196838d0c86
- https://github.com/vllm-project/vllm/pull/28126
- https://github.com/vllm-project/vllm/security/advisories/GHSA-8fr4-5q9j-m8gm
Get alerted when CVE-2025-66448 or the next vulnerability affects your stack