What’s Vulnerable › Vulnerabilities
CVE-2025-66451: LibreChat's Improper Input Validation in Prompt Creation API Enables Unauthorized Permission Changes
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-11 · updated 2026-10-07
- Weakness: CWE-20
Description
LibreChat is a ChatGPT clone with additional features. In versions 0.8.0 and below, when creating prompts, JSON requests are sent to define and modify the prompts via PATCH endpoint for prompt groups (/api/prompts/groups/:groupId). However, the request bodies are not sufficiently validated for proper input, enabling users to modify prompts in a way that was not intended as part of the front end system. The patchPromptGroup function passes req.body directly to updatePromptGroup() without filtering sensitive fields. This issue is fixed in version 0.8.1.
Affected products
- danny-avila LibreChat: before 0.8.1 — fixed in 0.8.1
How to fix
Upgrade to a fixed version: danny-avila LibreChat 0.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/danny-avila/LibreChat/commit/01413eea3d3c1454d32ca9704fa9640407839737
- https://github.com/danny-avila/LibreChat/security/advisories/GHSA-vpqq-5qr4-655h
Get alerted when CVE-2025-66451 or the next vulnerability affects your stack