What’s Vulnerable › Vulnerabilities
CVE-2025-66458: Lookyloo has multiple XSS due to unsafe use of f-strings in Markup
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-02 · updated 2026-09-25
- Weakness: CWE-79
Description
Lookyloo is a web interface that allows users to capture a website page and then display a tree of domains that call each other. Prior to 1.35.3, there are multiple XSS due to unsafe use of f-strings in Markup. The issue requires a malicious 3rd party server responding with a JSON document containing JS code in a script element. This vulnerability is fixed in 1.35.3.
Affected products
- lookyloo: before 1.35.3 — fixed in 1.35.3
How to fix
Upgrade to a fixed version: lookyloo 1.35.3. Check the vendor advisory for mitigations.
References
- https://github.com/Lookyloo/lookyloo/commit/b6ee2fee0afff0b35f37dd891bbce9d53ed8a290
- https://github.com/Lookyloo/lookyloo/security/advisories/GHSA-58h2-652v-gq87
Get alerted when CVE-2025-66458 or the next vulnerability affects your stack