What’s Vulnerable › Vulnerabilities
CVE-2025-66459: Lookyloo vulnerable to XSS due to unescaped error message passed to innerHTML
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-02 · updated 2026-09-25
- Weakness: CWE-79
Description
Lookyloo is a web interface that allows users to capture a website page and then display a tree of domains that call each other. Prior to 1.35.3, a XSS vulnerability can be triggered when a user submits a list of URLs to capture, one of them contains a HTML element, and the capture fails. Then, the error field is populated with an error message that contains the bad URL they tried to capture, triggering the XSS. This vulnerability is fixed in 1.35.3.
Affected products
- lookyloo: before 1.35.3 — fixed in 1.35.3
How to fix
Upgrade to a fixed version: lookyloo 1.35.3. Check the vendor advisory for mitigations.
References
- https://github.com/Lookyloo/lookyloo/commit/1850a34b8cec52438df3b544295b20cfa35f8ad1
- https://github.com/Lookyloo/lookyloo/commit/8c3ab96de44c1ce15646d734aa06faf884329116
- https://github.com/Lookyloo/lookyloo/commit/95cdc00fe37fd89790fa89bb3ee3fefa2da38442
- https://github.com/Lookyloo/lookyloo/security/advisories/GHSA-hvmh-j2jx-48wg
Get alerted when CVE-2025-66459 or the next vulnerability affects your stack