What’s Vulnerable › Vulnerabilities
CVE-2025-66460: Lookyloo vulnerable to XSS due to lack of escaping in HTML elements passed to Datatables
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-02 · updated 2026-09-25
- Weakness: CWE-79
Description
Lookyloo is a web interface that allows users to capture a website page and then display a tree of domains that call each other. Prior to 1.35.3, Lookyloo passed improperly escaped values to cells rendered in datatables using the orthogonal-data feature. It is definitely exploitable from the popup view, but it is most probably also exploitable in many other places. This vulnerability is fixed in 1.35.3.
Affected products
- lookyloo: before 1.35.3 — fixed in 1.35.3
How to fix
Upgrade to a fixed version: lookyloo 1.35.3. Check the vendor advisory for mitigations.
References
- https://github.com/Lookyloo/lookyloo/commit/63b39311f6b251a671895d97174345faf1b18e6e
- https://github.com/Lookyloo/lookyloo/security/advisories/GHSA-r93r-7jfr-99c3
Get alerted when CVE-2025-66460 or the next vulnerability affects your stack