What’s Vulnerable › Vulnerabilities
CVE-2025-66469: NiceGUI Reflected XSS in ui.add_css, ui.add_scss, and ui.add_sass via Style Injection
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-09 · updated 2026-10-19
- Weakness: CWE-79
Description
NiceGUI is a Python-based UI framework. Versions 3.3.1 and below are vulnerable to Reflected XSS through its ui.add_css, ui.add_scss, and ui.add_sass functions. The functions lack proper sanitization or encoding for the JavaScript context they generate. An attacker can break out of the intended <style> or <script> tags by injecting closing tags (e.g., </style> or </script>), allowing for the execution of arbitrary JavaScript. This issue is fixed in version 3.4.0.
Affected products
- zauberzeug nicegui: before 3.4.0 — fixed in 3.4.0
How to fix
Upgrade to a fixed version: zauberzeug nicegui 3.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/zauberzeug/nicegui/commit/a8fd25b7d5e23afb1952d0f60a1940e18b5f1ca8
- https://github.com/zauberzeug/nicegui/security/advisories/GHSA-72qc-wxch-74mg
- https://github.com/zauberzeug/nicegui/security/advisories/GHSA-72qc-wxch-74mg
Get alerted when CVE-2025-66469 or the next vulnerability affects your stack