What’s Vulnerable › Vulnerabilities
CVE-2025-66470: NiceGUI Stored/Reflected XSS in ui.interactive_image via unsanitized SVG content
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-09 · updated 2026-10-07
- Weakness: CWE-79
Description
NiceGUI is a Python-based UI framework. Versions 3.3.1 and below are subject to a XSS vulnerability through the ui.interactive_image component of NiceGUI. The component renders SVG content using Vue's v-html directive without any sanitization. This allows attackers to inject malicious HTML or JavaScript via the SVG <foreignObject> tag whenever the image component is rendered or updated. This is particularly dangerous for dashboards or multi-user applications displaying user-generated content or annotations. This issue is fixed in version 3.4.0.
Affected products
- zauberzeug nicegui: before 3.4.0 — fixed in 3.4.0
How to fix
Upgrade to a fixed version: zauberzeug nicegui 3.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/zauberzeug/nicegui/commit/58ad0b36e19922de16bbc79ea3ddd29851b1a3e3
- https://github.com/zauberzeug/nicegui/security/advisories/GHSA-2m4f-cg75-76w2
- https://github.com/zauberzeug/nicegui/security/advisories/GHSA-2m4f-cg75-76w2
Get alerted when CVE-2025-66470 or the next vulnerability affects your stack