What’s Vulnerable › Vulnerabilities

CVE-2025-66474: XWiki vulnerable to remote code execution through insufficient protection against {{/html}} injection

Description

XWiki Rendering is a generic rendering system that converts textual input in a given syntax (wiki syntax, HTML, etc) into another syntax (XHTML, etc). Versions 16.10.9 and below, 17.0.0-rc-1 through 17.4.2 and 17.5.0-rc-1 through 17.5.0 have insufficient protection against {{/html}} injection, which attackers can exploit through RCE. Any user who can edit their own profile or any other document can execute arbitrary script macros, including Groovy and Python macros, which enable remote code execution as well as unrestricted read and write access to all wiki contents. This issue is fixed in versions 16.10.10, 17.4.3 and 17.6.0-rc-1.

Affected products

How to fix

Upgrade to a fixed version: xwiki-rendering 16.10.10, 17.4.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-66474 or the next vulnerability affects your stack