What’s Vulnerable › Vulnerabilities
CVE-2025-66476: Vim for Windows Uncontrolled Search Path Element Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-02 · updated 2026-10-18
- Weakness: CWE-427
Description
Vim is an open source, command line text editor. Prior to version 9.1.1947, an uncontrolled search path vulnerability on Windows allows Vim to execute malicious executables placed in the current working directory for the current edited file. On Windows, when using cmd.exe as a shell, Vim resolves external commands by searching the current working directory before system paths. When Vim invokes tools such as findstr for :grep, external commands or filters via :!, or compiler/:make commands, it may inadvertently run a malicious executable present in the same directory as the file being edited. The issue affects Vim for Windows prior to version 9.1.1947.
Affected products
- vim/vim: before 9.1.1947 — fixed in 9.1.1947
How to fix
Upgrade to a fixed version: vim/vim 9.1.1947. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/083ec6d9a3b7b09006e0ce69ac802597d25
- https://github.com/vim/vim/releases/tag/v9.1.1947
- https://github.com/vim/vim/security/advisories/GHSA-g77q-xrww-p834
- http://www.openwall.com/lists/oss-security/2025/12/02/5
Get alerted when CVE-2025-66476 or the next vulnerability affects your stack