What’s Vulnerable › Vulnerabilities
CVE-2025-66516: Apache Tika core, Apache Tika parsers, Apache Tika PDF parser module: Update to CVE-2025-54988 to expand scope of artifacts affected
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 89.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-04 · updated 2026-06-17
- Weakness: CWE-611
Description
Critical XXE in Apache Tika tika-core (1.13-3.2.1), tika-pdf-module (2.0.0-3.2.1) and tika-parsers (1.13-1.28.5) modules on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF. This CVE covers the same vulnerability as in CVE-2025-54988. However, this CVE expands the scope of affected packages in two ways. First, while the entrypoint for the vulnerability was the tika-parser-pdf-module as reported in CVE-2025-54988, the vulnerability and its fix were in tika-core. Users who upgraded the tika-parser-pdf-module but did not upgrade tika-core to >= 3.2.2 would still be vulnerable. Second, the original report failed to mention that in the 1.x Tika releases, the PDFParser was in the "org.apache.tika:tika-parsers" module.
Affected products
- Apache Software Foundation Apache Tika: from 1.13 before 3.2.2 — fixed in 3.2.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Tika 3.2.2. Check the vendor advisory for mitigations.
References
- https://cve.org/CVERecord?id=CVE-2025-54988
- https://lists.apache.org/thread/s5x3k93nhbkqzztp1olxotoyjpdlps9k
Get alerted when CVE-2025-66516 or the next vulnerability affects your stack