What’s Vulnerable › Vulnerabilities
CVE-2025-66518: Apache Kyuubi: Unauthorized directory access due to missing path normalization
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-05 · updated 2026-10-07
- Weakness: CWE-27
Description
Any client who can access to Apache Kyuubi Server via Kyuubi frontend protocols can bypass server-side config kyuubi.session.local.dir.allow.list and use local files which are not listed in the config. This issue affects Apache Kyuubi: from 1.6.0 through 1.10.2. Users are recommended to upgrade to version 1.10.3 or upper, which fixes the issue.
Affected products
- Apache Software Foundation Apache Kyuubi: from 1.6.0 before 1.10.3 — fixed in 1.10.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Kyuubi 1.10.3. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/xp460bwbyzdhho34ljd4nchyt2fmhodl
- http://www.openwall.com/lists/oss-security/2026/01/05/1
Get alerted when CVE-2025-66518 or the next vulnerability affects your stack