What’s Vulnerable › Vulnerabilities
CVE-2025-66561: SysReptor Vulnerable to an Authenticated Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-04 · updated 2026-10-18
- Weakness: CWE-79
Description
SysReptor is a fully customizable pentest reporting platform. Prior to 2025.102, there is a Stored Cross-Site Scripting (XSS) vulnerability allows authenticated users to execute malicious JavaScript in the context of other logged-in users by uploading malicious JavaScript files in the web UI. This vulnerability is fixed in 2025.102.
Affected products
- Syslifters sysreptor: before 2025.102 — fixed in 2025.102
How to fix
Upgrade to a fixed version: Syslifters sysreptor 2025.102. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-66561 or the next vulnerability affects your stack