What’s Vulnerable › Vulnerabilities
CVE-2025-66562: TUUI vulnerable to Remote Code Execution (RCE) via XSS in Markdown ECharts Rendering
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-05 · updated 2026-09-25
- Weakness: CWE-79
Description
TUUI is a desktop MCP client designed as a tool unitary utility integration. Prior to 1.3.4, a critical Remote Code Execution (RCE) vulnerability exists in Tuui due to an unsafe Cross-Site Scripting (XSS) flaw in the Markdown rendering component. Tuui allows the execution of arbitrary JavaScript within ECharts code blocks. Combined with an exposed IPC interface that allows spawning processes, an attacker can execute arbitrary system commands on the victim's machine simply by having them view a malicious Markdown message. This vulnerability is fixed in 1.3.4.
Affected products
- AI-QL tuui: before 1.3.4 — fixed in 1.3.4
How to fix
Upgrade to a fixed version: AI-QL tuui 1.3.4. Check the vendor advisory for mitigations.
References
- https://github.com/AI-QL/tuui/commit/f673fa5b4d76e8236c7d9506d0727875cfa79cc1
- https://github.com/AI-QL/tuui/releases/tag/v1.3.4
- https://github.com/AI-QL/tuui/security/advisories/GHSA-qjhq-rgmr-6c3g
Get alerted when CVE-2025-66562 or the next vulnerability affects your stack