What’s Vulnerable › Vulnerabilities
CVE-2025-66566: yawkat LZ4 Java has a possible information leak in Java safe decompressor
- Severity: high (CVSS 8.2 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-05 · updated 2026-09-25
- Weakness: CWE-201
Description
yawkat LZ4 Java provides LZ4 compression for Java. Insufficient clearing of the output buffer in Java-based decompressor implementations in lz4-java 1.10.0 and earlier allows remote attackers to read previous buffer contents via crafted compressed input. In applications where the output buffer is reused without being cleared, this may lead to disclosure of sensitive data. JNI-based implementations are not affected. This vulnerability is fixed in 1.10.1.
Affected products
- yawkat lz4-java: before 1.10.1
References
- https://github.com/yawkat/lz4-java/commit/33d180cb70c4d93c80fb0dc3ab3002f457e93840
- https://github.com/yawkat/lz4-java/security/advisories/GHSA-cmp6-m4wj-q63q
Get alerted when CVE-2025-66566 or the next vulnerability affects your stack