What’s Vulnerable › Vulnerabilities
CVE-2025-66567: ruby-saml has a SAML authentication bypass due to namespace handling (parser differential)
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-09 · updated 2026-10-14
- Weakness: CWE-347
Description
The ruby-saml library is for implementing the client side of a SAML authorization. ruby-saml versions up to and including 1.12.4 contain an authentication bypass vulnerability due to an incomplete fix for CVE-2025-25292. ReXML and Nokogiri parse XML differently, generating entirely different document structures from the same input. This allows an attacker to execute a Signature Wrapping attack. This issue is fixed in version 1.18.0.
Affected products
- SAML-Toolkits ruby-saml: before 1.18.0 — fixed in 1.18.0
- Rubygems Ruby-Saml: before 1.18.0; 0.0.5, 0.0.6, 0.0.7, 0.0.8, 0.2.1, 0.2.2 (+81) — fixed in 1.18.0
How to fix
Upgrade to a fixed version: SAML-Toolkits ruby-saml 1.18.0; Rubygems Ruby-Saml 1.18.0. Check the vendor advisory for mitigations.
References
- https://github.com/SAML-Toolkits/ruby-saml/commit/e9c1cdbd0f9afa467b585de279db0cbd0fb8ae97
- https://github.com/SAML-Toolkits/ruby-saml/security/advisories/GHSA-9v8j-x534-2fx3
- https://github.com/advisories/GHSA-754f-8gm6-c4r2
Get alerted when CVE-2025-66567 or the next vulnerability affects your stack