What’s Vulnerable › Vulnerabilities
CVE-2025-66580: Dive has Cross-Site Scripting vulnerability that can escalate to Remote Code Execution
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-19 · updated 2026-06-17
- Weakness: CWE-94
Description
Dive is an open-source MCP Host Desktop Application that enables integration with function-calling LLMs. A critical Stored Cross-Site Scripting (XSS) vulnerability exists in versions prior to 0.11.1 in the Mermaid diagram rendering component. The application allows the execution of arbitrary JavaScript via `javascript:`. An attacker can exploit this to inject a malicious Model Context Protocol (MCP) server configuration, leading to Remote Code Execution (RCE) on the victim's machine when the node is clicked. Version 0.11.1 fixes the issue.
Affected products
- OpenAgentPlatform Dive: before 0.11.1 — fixed in 0.11.1
How to fix
Upgrade to a fixed version: OpenAgentPlatform Dive 0.11.1. Check the vendor advisory for mitigations.
References
- https://github.com/OpenAgentPlatform/Dive/security/advisories/GHSA-xv8m-365j-x6h2
- https://github.com/OpenAgentPlatform/Dive/security/advisories/GHSA-xv8m-365j-x6h2
Get alerted when CVE-2025-66580 or the next vulnerability affects your stack