What’s Vulnerable › Vulnerabilities
CVE-2025-66581: Frappe LMS is Missing Server-Side Authorization in Business Logic
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-05 · updated 2026-09-25
- Weakness: CWE-863
Description
Frappe Learning Management System (LMS) is a learning system that helps users structure their content. Prior to 2.41.0, a flaw in the server-side authorization logic allowed authenticated users to perform actions beyond their assigned roles across multiple features. Because the affected endpoints relied on client-side or UI-level checks instead of enforcing permissions on the server, users with low-privileged roles (such as students) could perform operations intended only for instructors or administrators via directly using the API's. This vulnerability is fixed in 2.41.0.
Affected products
- frappe Learning: before 2.41.0 — fixed in 2.41.0
How to fix
Upgrade to a fixed version: frappe Learning 2.41.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-66581 or the next vulnerability affects your stack