What’s Vulnerable › Vulnerabilities
CVE-2025-6663: GStreamer H266 Codec Parsing Stack-based Buffer Overflow Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-07 · updated 2026-06-17
- Weakness: CWE-121
Description
GStreamer H266 Codec Parsing Stack-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GStreamer. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation. The specific flaw exists within the parsing of H266 sei messages. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a fixed-length stack-based buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-27381.
Affected products
- GStreamer: from 1.26.0 before 1.26.3 — fixed in 1.26.3
How to fix
Upgrade to a fixed version: GStreamer 1.26.3. Check the vendor advisory for mitigations.
References
- https://gitlab.freedesktop.org/tpm/gstreamer/-/commit/eedd01ac3dfeb60e36a44bb61a6d0418454e8416
- https://www.zerodayinitiative.com/advisories/ZDI-25-467/
Get alerted when CVE-2025-6663 or the next vulnerability affects your stack