What’s Vulnerable › Vulnerabilities
CVE-2025-66631: CSLA .NET is vulnerable to Remote Code Execution via WcfProxy
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-09 · updated 2026-10-07
- Weakness: CWE-502
Description
CSLA .NET is a framework designed for the development of reusable, object-oriented business layers for applications. Versions 5.5.4 and below allow the use of WcfProxy. WcfProxy uses the now-obsolete NetDataContractSerializer (NDCS) and is vulnerable to remote code execution during deserialization. This vulnerability is fixed in version 6.0.0. To workaround this issue, remove the WcfProxy in data portal configurations.
Affected products
- MarimerLLC csla: before 6.0.0 — fixed in 6.0.0
How to fix
Upgrade to a fixed version: MarimerLLC csla 6.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/MarimerLLC/csla/issues/4001
- https://github.com/MarimerLLC/csla/pull/4018
- https://github.com/MarimerLLC/csla/security/advisories/GHSA-wq34-7f4g-953v
Get alerted when CVE-2025-66631 or the next vulnerability affects your stack