What’s Vulnerable › Vulnerabilities
CVE-2025-66648: `vega-functions` vulnerable to Cross-site Scripting via `setdata` function
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-05 · updated 2026-10-14
- Weakness: CWE-79
Description
vega-functions provides function implementations for the Vega expression language. Prior to version 6.1.1, for sites that allow users to supply untrusted user input, malicious use of an internal function (not part of the public API) could be used to run unintentional javascript (XSS). This issue is fixed in vega-functions `6.1.1`. There is no workaround besides upgrading. Using `vega.expressionInterpreter` as described in CSP safe mode does not prevent this issue.
Affected products
- Vega-Functions Project Vega-Functions: before 6.1.1 — fixed in 6.1.1
How to fix
Upgrade to a fixed version: Vega-Functions Project Vega-Functions 6.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-66648 or the next vulnerability affects your stack