What’s Vulnerable › Vulnerabilities
CVE-2025-66675: Apache Struts: File leak in multipart request processing causes disk exhaustion (DoS) - version ranges fixed
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-10 · updated 2026-10-14
- Weakness: CWE-459
Description
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.4, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue. It's related to https://cve.org/CVERecord?id=CVE-2025-64775 - this CVE addresses missing affected version 6.7.4
Affected products
- Apache Struts: from 2.0.0 through 2.3.37; from 2.5.0 through 2.5.33; from 6.0.0 before 6.8.0; from 7.0.0 before 7.1.1 — fixed in 6.8.0, 7.1.1
How to fix
Upgrade to a fixed version: Apache Struts 6.8.0, 7.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-66675 or the next vulnerability affects your stack