What’s Vulnerable › Vulnerabilities
CVE-2025-66692
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-20 · updated 2026-06-17
- Weakness: CWE-126
Description
A buffer over-read in the PublicKey::verify() method of Binance - Trust Wallet Core before commit 5668c67 allows attackers to cause a Denial of Service (DoS) via a crafted input.
Affected products
- Trustwallet Trust Wallet Core: before 4.4.0 — fixed in 4.4.0
How to fix
Upgrade to a fixed version: Trustwallet Trust Wallet Core 4.4.0. Check the vendor advisory for mitigations.
References
- https://gist.github.com/inkman97/b791189338f73b758c31a7db3cd50c2d
- https://github.com/trustwallet/wallet-core/commit/5668c67
Get alerted when CVE-2025-66692 or the next vulnerability affects your stack