What’s Vulnerable › Vulnerabilities
CVE-2025-66844
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-15 · updated 2026-10-23
- Weakness: CWE-918
Description
In grav <1.7.49.5, a SSRF (Server-Side Request Forgery) vector may be triggered via Twig templates when page content is processed by Twig and the configuration allows undefined PHP functions to be registered
Affected products
- getgrav grav: before 1.7.49.5 — fixed in 1.7.49.5
How to fix
Upgrade to a fixed version: getgrav grav 1.7.49.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-66844 or the next vulnerability affects your stack