What’s Vulnerable › Vulnerabilities
CVE-2025-6685: ATEN eco DC Missing Authorization Privilege Escalation Vulnerability
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-02 · updated 2026-06-17
- Weakness: CWE-862
Description
ATEN eco DC Missing Authorization Privilege Escalation Vulnerability. This vulnerability allows remote attackers to escalate privileges on affected installations of ATEN eco DC. Authentication is required to exploit this vulnerability. The specific flaw exists within the web-based interface. The issue results from the lack of validating the assigned user role when handling requests. An attacker can leverage this vulnerability to escalate privileges to resources normally protected from the user. Was ZDI-CAN-26647.
Affected products
- ATEN eco DC: before 1.2.116 — fixed in 1.2.116
How to fix
Upgrade to a fixed version: ATEN eco DC 1.2.116. Check the vendor advisory for mitigations.
References
- https://www.aten.com/global/en/supportcenter/info/security-advisory/25/
- https://www.zerodayinitiative.com/advisories/ZDI-25-650/
Get alerted when CVE-2025-6685 or the next vulnerability affects your stack