What’s Vulnerable › Vulnerabilities
CVE-2025-6688: Simple Payment 1.3.6 - 2.3.8 - Authentication Bypass to Admin
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-27 · updated 2026-06-17
- Weakness: CWE-288
Description
The Simple Payment plugin for WordPress is vulnerable to Authentication Bypass in versions 1.3.6 to 2.3.8. This is due to the plugin not properly verifying a user's identity prior to logging them in through the create_user() function. This makes it possible for unauthenticated attackers to log in as administrative users.
Affected products
- idokd Simple Payment: from 1.3.6 before 2.3.9 — fixed in 2.3.9
How to fix
Upgrade to a fixed version: idokd Simple Payment 2.3.9. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3318371/simple-payment/tags/2.3.9/simple-payment-plugin.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8b4e2f87-e3ad-4f1b-b647-f5e5a49f691b?source=cve
Get alerted when CVE-2025-6688 or the next vulnerability affects your stack