What’s Vulnerable › Vulnerabilities
CVE-2025-67030
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-25 · updated 2026-09-16
- Weakness: CWE-22
Description
Directory Traversal vulnerability in the extractFile method of org.codehaus.plexus.util.Expand in plexus-utils before 6d780b3378829318ba5c2d29547e0012d5b29642. This allows an attacker to execute arbitrary code
Affected products
- codehaus-plexus Plexus-Utils: before 3.6.1; from 4.0.0 before 4.0.3 — fixed in 3.6.1, 4.0.3
How to fix
Upgrade to a fixed version: codehaus-plexus Plexus-Utils 3.6.1, 4.0.3. Check the vendor advisory for mitigations.
References
- https://gist.github.com/weaver4VD/3216dac645220f8c9b488362f61241ec
- https://github.com/codehaus-plexus/plexus-utils/commit/6d780b3378829318ba5c2d29547e0012d5b29642
- https://github.com/codehaus-plexus/plexus-utils/issues/294
- https://github.com/codehaus-plexus/plexus-utils/pull/295
- https://github.com/codehaus-plexus/plexus-utils/pull/296
- https://access.redhat.com/errata/RHSA-2026:17668
- https://access.redhat.com/errata/RHSA-2026:18054
- https://access.redhat.com/errata/RHSA-2026:18055
- https://access.redhat.com/errata/RHSA-2026:18059
- https://access.redhat.com/errata/RHSA-2026:35990
- https://access.redhat.com/errata/RHSA-2026:35991
- https://access.redhat.com/errata/RHSA-2026:35992
Get alerted when CVE-2025-67030 or the next vulnerability affects your stack