What’s Vulnerable › Vulnerabilities
CVE-2025-6704
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 11.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-21 · updated 2026-06-17
- Weakness: CWE-78
Description
An arbitrary file writing vulnerability in the Secure PDF eXchange (SPX) feature of Sophos Firewall versions older than 21.0 MR2 (21.0.2) can lead to pre-auth remote code execution, if a specific configuration of SPX is enabled in combination with the firewall running in High Availability (HA) mode.
Affected products
- Sophos Firewall: before 21.0.2 — fixed in 21.0.2
How to fix
Upgrade to a fixed version: Sophos Firewall 21.0.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-6704 or the next vulnerability affects your stack