What’s Vulnerable › Vulnerabilities
CVE-2025-6706: Running certain aggregation operations with the SBE engine may lead to unexpected behavior on MongoDB Server
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-26 · updated 2026-06-17
- Weakness: CWE-416
Description
An authenticated user may trigger a use after free that may result in MongoDB Server crash and other unexpected behavior, even if the user does not have authorization to shut down a server. The crash is triggered on affected versions by issuing an aggregation framework operation using a specific combination of rarely-used aggregation pipeline expressions. This issue affects MongoDB Server v6.0 version prior to 6.0.21, MongoDB Server v7.0 version prior to 7.0.17 and MongoDB Server v8.0 version prior to 8.0.4 when the SBE engine is enabled.
Affected products
- MongoDB: from 6.0.0 before 6.0.21; from 7.0.0 before 7.0.17; from 8.0.0 before 8.0.4 — fixed in 6.0.21, 7.0.17, 8.0.4
How to fix
Upgrade to a fixed version: MongoDB 6.0.21, 7.0.17, 8.0.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-6706 or the next vulnerability affects your stack