What’s Vulnerable › Vulnerabilities
CVE-2025-6707: Race condition in privilege cache invalidation cycle
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-26 · updated 2026-06-17
- Weakness: CWE-863
Description
Under certain conditions, an authenticated user request may execute with stale privileges following an intentional change by an authorized administrator. This issue affects MongoDB Server v5.0 version prior to 5.0.31, MongoDB Server v6.0 version prior to 6.0.24, MongoDB Server v7.0 version prior to 7.0.21 and MongoDB Server v8.0 version prior to 8.0.5.
Affected products
- MongoDB: from 5.0.0 before 5.0.31; from 6.0.0 before 6.0.24; from 7.0.0 before 7.0.21; from 8.0.0 before 8.0.5 — fixed in 5.0.31, 6.0.24, 7.0.21, 8.0.5
How to fix
Upgrade to a fixed version: MongoDB 5.0.31, 6.0.24, 7.0.21, 8.0.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-6707 or the next vulnerability affects your stack