What’s Vulnerable › Vulnerabilities
CVE-2025-6709: Pre-Authentication Denial of Service Vulnerability in MongoDB Server's OIDC Authentication
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-26 · updated 2026-06-17
- Weakness: CWE-20
Description
The MongoDB Server is susceptible to a denial of service vulnerability due to improper handling of specific date values in JSON input when using OIDC authentication. This can be reproduced using the mongo shell to send a malicious JSON payload leading to an invariant failure and server crash. This issue affects MongoDB Server v7.0 versions prior to 7.0.17 and MongoDB Server v8.0 versions prior to 8.0.5. The same issue affects MongoDB Server v6.0 versions prior to 6.0.21, but an attacker can only induce denial of service after authenticating.
Affected products
- MongoDB: from 6.0.0 before 6.0.21; from 7.0.0 before 7.0.17; from 8.0.0 before 8.0.5 — fixed in 6.0.21, 7.0.17, 8.0.5
How to fix
Upgrade to a fixed version: MongoDB 6.0.21, 7.0.17, 8.0.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-6709 or the next vulnerability affects your stack