What’s Vulnerable › Vulnerabilities
CVE-2025-67109
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-23 · updated 2026-07-05
- Weakness: CWE-298
Description
Improper verification of the time certificate in Eclipse Cyclone DDS before v0.10.5 allows attackers to bypass certificate checks and execute commands with System privileges.
Affected products
- Eclipse Foundation Eclipse Cyclone DDS: before 0.10.5 — fixed in 0.10.5
How to fix
Upgrade to a fixed version: Eclipse Foundation Eclipse Cyclone DDS 0.10.5. Check the vendor advisory for mitigations.
References
- https://gist.github.com/lkloliver/669e15bc7e6194133e4ee1026ce157e6
- https://github.com/eclipse-cyclonedds/cyclonedds/blob/master/src/ddsrt/src/time/posix/time.c#L28
- https://github.com/eclipse-cyclonedds/cyclonedds/blob/master/src/security/builtin_plugins/authentication/src/auth_utils.c#L84
Get alerted when CVE-2025-67109 or the next vulnerability affects your stack