What’s Vulnerable › Vulnerabilities
CVE-2025-6711: Incomplete Redaction of Sensitive Information in MongoDB Server Logs
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-07 · updated 2026-06-17
- Weakness: CWE-532
Description
An issue has been identified in MongoDB Server where unredacted queries may inadvertently appear in server logs when certain error conditions are encountered. This issue affects MongoDB Server v8.0 versions prior to 8.0.5, MongoDB Server v7.0 versions prior to 7.0.18 and MongoDB Server v6.0 versions prior to 6.0.21.
Affected products
- MongoDB: from 6.0.0 before 6.0.21; from 7.0.0 before 7.0.18; from 8.0.0 before 8.0.5 — fixed in 6.0.21, 7.0.18, 8.0.5
How to fix
Upgrade to a fixed version: MongoDB 6.0.21, 7.0.18, 8.0.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-6711 or the next vulnerability affects your stack