What’s Vulnerable › Vulnerabilities
CVE-2025-67111
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-23 · updated 2026-06-17
- Weakness: CWE-190
Description
An integer overflow in the RTPS protocol implementation of OpenDDS DDS before v3.33.0 allows attackers to cause a Denial of Service (DoS) via a crafted message.
Affected products
- OpenDDS: before 3.33.0 — fixed in 3.33.0
How to fix
Upgrade to a fixed version: OpenDDS 3.33.0. Check the vendor advisory for mitigations.
References
- https://gist.github.com/lkloliver/fcc5da83b4cba137ce95177a9afc4126
- https://github.com/lkloliver/poc/blob/main/POC_OpenDDS.md
Get alerted when CVE-2025-67111 or the next vulnerability affects your stack