What’s Vulnerable › Vulnerabilities
CVE-2025-6713: MongoDB Server may be susceptible to privilege escalation due to $mergeCursors stage
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-07 · updated 2026-06-17
- Weakness: CWE-285
Description
An unauthorized user may leverage a specially crafted aggregation pipeline to access data without proper authorization due to improper handling of the $mergeCursors stage in MongoDB Server. This may lead to access to data without further authorisation. This issue affects MongoDB Server MongoDB Server v8.0 versions prior to 8.0.7, MongoDB Server v7.0 versions prior to 7.0.19 and MongoDB Server v6.0 versions prior to 6.0.22
Affected products
- MongoDB: from 6.0.0 before 6.0.22; from 7.0.0 before 7.0.19; from 8.0.0 before 8.0.7 — fixed in 6.0.22, 7.0.19, 8.0.7
How to fix
Upgrade to a fixed version: MongoDB 6.0.22, 7.0.19, 8.0.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-6713 or the next vulnerability affects your stack