What’s Vulnerable › Vulnerabilities
CVE-2025-67269
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-02 · updated 2026-07-15
- Weakness: CWE-191
Description
An integer underflow vulnerability exists in the `nextstate()` function in `gpsd/packet.c` of gpsd versions prior to commit `ffa1d6f40bca0b035fc7f5e563160ebb67199da7`. When parsing a NAVCOM packet, the payload length is calculated using `lexer->length = (size_t)c - 4` without checking if the input byte `c` is less than 4. This results in an unsigned integer underflow, setting `lexer->length` to a very large value (near `SIZE_MAX`). The parser then enters a loop attempting to consume this massive number of bytes, causing 100% CPU utilization and a Denial of Service (DoS) condition.
Affected products
- ntpsec gpsd: before 3.27.1 — fixed in 3.27.1
How to fix
Upgrade to a fixed version: ntpsec gpsd 3.27.1. Check the vendor advisory for mitigations.
References
- https://github.com/Jaenact/gspd_cve/blob/main/CVE-2025-67269/README.md
- https://gitlab.com/gpsd/gpsd
- https://gitlab.com/gpsd/gpsd/-/commit/ffa1d6f40bca0b035fc7f5e563160ebb67199da7
- https://access.redhat.com/errata/RHSA-2026:0770
- https://access.redhat.com/errata/RHSA-2026:0771
- https://access.redhat.com/security/cve/CVE-2025-67269
- https://bugzilla.redhat.com/show_bug.cgi?id=2426810
- https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-67269.json
Get alerted when CVE-2025-67269 or the next vulnerability affects your stack