What’s Vulnerable › Vulnerabilities
CVE-2025-6743: WoodMart <= 8.2.3 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The Woodmart theme for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'multiple_markers' attribute in all versions up to, and including, 8.2.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- xtemos WoodMart: before 8.2.4 — fixed in 8.2.4
How to fix
Upgrade to a fixed version: xtemos WoodMart 8.2.4. Check the vendor advisory for mitigations.
References
- https://themeforest.net/item/woodmart-woocommerce-wordpress-theme/20264492
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4b881509-572b-4e2d-9e75-defaa2cc32dc?source=cve
Get alerted when CVE-2025-6743 or the next vulnerability affects your stack