What’s Vulnerable › Vulnerabilities
CVE-2025-67477: Stored XSS through a system message in Special:ApiSandbox
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-03 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files resources/src/mediawiki.Special.Apisandbox/ApiSandboxLayout.Js. This issue affects MediaWiki: from * before 1.44.3, 1.45.1.
Affected products
- Wikimedia Foundation MediaWiki: from 1.44.0 before 1.44.3; 1.45.0 — fixed in 1.44.3
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.44.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-67477 or the next vulnerability affects your stack