What’s Vulnerable › Vulnerabilities
CVE-2025-67508: gardenctl is vulnerable to Command Injection when used with non‑POSIX shells
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-12 · updated 2026-10-07
- Weakness: CWE-77
Description
gardenctl is a command-line client for the Gardener which configures access to clusters and cloud provider CLI tools. When using non‑POSIX shells such as Fish and PowerShell, versions 2.11.0 and below of gardenctl allow an attacker with administrative privileges for a Gardener project to craft malicious credential values. The forged credential values are used in infrastructure Secret objects that break out of the intended string context when evaluated in Fish or PowerShell environments used by the Gardener service operators. This issue is fixed in version 2.12.0.
Affected products
- gardener gardenctl-v2: before 2.12.0 — fixed in 2.12.0
How to fix
Upgrade to a fixed version: gardener gardenctl-v2 2.12.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-67508 or the next vulnerability affects your stack