What’s Vulnerable › Vulnerabilities
CVE-2025-67543: WordPress Essential Widgets plugin <= 2.2.2 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-09 · updated 2026-10-07
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Catch Themes Essential Widgets essential-widgets allows Stored XSS.This issue affects Essential Widgets: from n/a through <= 2.2.2.
Affected products
- catchthemes Essential Widgets: before 2.3; before 2.8 — fixed in 2.3, 2.8
How to fix
Upgrade to a fixed version: catchthemes Essential Widgets 2.3, 2.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-67543 or the next vulnerability affects your stack