What’s Vulnerable › Vulnerabilities
CVE-2025-6756: Ultra Addons for Contact Form 7 <= 3.5.21 - Authenticated (Contributor+) Stored Cross-Site Scripting via UACF7_CUSTOM_FIELDS Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ultra Addons for Contact Form 7 plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's UACF7_CUSTOM_FIELDS shortcode in all versions up to, and including, 3.5.21 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Themefic Ultimate Addons for Contact Form 7: before 3.5.22 — fixed in 3.5.22
How to fix
Upgrade to a fixed version: Themefic Ultimate Addons for Contact Form 7 3.5.22. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ultimate-addons-for-contact-form-7/tags/3.5.21/addons/dynamic-text/inc/shortcode.php#L113
- https://plugins.trac.wordpress.org/changeset/3319449/
- https://wordpress.org/plugins/ultimate-addons-for-contact-form-7/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5b839658-c472-40f0-855f-7201baeb790f?source=cve
Get alerted when CVE-2025-6756 or the next vulnerability affects your stack