What’s Vulnerable › Vulnerabilities

CVE-2025-67648: Shopware's inproper input validation can lead to Reflected XSS through Storefront Login Page

Description

Shopware is an open commerce platform. Versions 6.4.6.0 through 6.6.10.9 and 6.7.0.0 through 6.7.5.0 have a Reflected XSS vulnerability in AuthController.php. A request parameter from the login page URL is directly rendered within the Twig template of the Storefront login page without further processing or input validation. This allows direct code injection into the template via the URL parameter, waitTime, which lacks proper input validation. This issue is fixed in versions 6.6.10.10 and 6.7.5.1.

Affected products

How to fix

Upgrade to a fixed version: shopware 6.6.10.10, 6.7.5.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-67648 or the next vulnerability affects your stack