What’s Vulnerable › Vulnerabilities
CVE-2025-67721: Aircompressor's Snappy and LZ4 Java-based decompressor implementation can leak information from reused output buffer
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-12 · updated 2026-10-07
- Weakness: CWE-125
Description
Aircompressor is a library with ports of the Snappy, LZO, LZ4, and Zstandard compression algorithms to Java. In versions 3.3 and below, incorrect handling of malformed data in Java-based decompressor implementations for Snappy and LZ4 allow remote attackers to read previous buffer contents via crafted compressed input. With certain crafted compressed inputs, elements from the output buffer can end up in the uncompressed output, potentially leaking sensitive data. This is relevant for applications that reuse the same output buffer to uncompress multiple inputs. This can be the case of a web server that allocates a fix-sized buffer for performance purposes. There is similar vulnerability in GHSA-cmp6-m4wj-q63q. This issue is fixed in version 3.4.
Affected products
- airlift aircompressor: before 2.0.3; from 3.0 before 3.4 — fixed in 2.0.3, 3.4
How to fix
Upgrade to a fixed version: airlift aircompressor 2.0.3, 3.4. Check the vendor advisory for mitigations.
References
- https://github.com/airlift/aircompressor/commit/f2b489b398779b40c1ee29ddb11d7edef54ddc15
- https://github.com/airlift/aircompressor/commit/ff12c4d5757c9d6d1de3d39a10402f1f84f9b765
- https://github.com/airlift/aircompressor/security/advisories/GHSA-vx9q-rhv9-3jvg
Get alerted when CVE-2025-67721 or the next vulnerability affects your stack