What’s Vulnerable › Vulnerabilities

CVE-2025-67723: Discourse vulnerable to stored Cross-site Scripting via Katex in discourse-math plugin

Description

Discourse is an open source discussion platform. Versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 have a content-security-policy-mitigated cross-site scriptinv vulnerability on the Discourse Math plugin when using its KaTeX variant. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. As a workaround, the Discourse Math plugin can be disabled, or the Mathjax provider can be used instead of KaTeX.

Affected products

How to fix

Upgrade to a fixed version: discourse 2025.11.2, 3.5.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-67723 or the next vulnerability affects your stack