What’s Vulnerable › Vulnerabilities
CVE-2025-67729: lmdeploy vulnerable to Arbitrary Code Execution via Insecure Deserialization in torch.load()
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-26 · updated 2026-10-07
- Weakness: CWE-502
Description
LMDeploy is a toolkit for compressing, deploying, and serving LLMs. Prior to version 0.11.1, an insecure deserialization vulnerability exists in lmdeploy where torch.load() is called without the weights_only=True parameter when loading model checkpoint files. This allows an attacker to execute arbitrary code on the victim's machine when they load a malicious .bin or .pt model file. This issue has been patched in version 0.11.1.
Affected products
- InternLM lmdeploy: before 0.11.1 — fixed in 0.11.1
How to fix
Upgrade to a fixed version: InternLM lmdeploy 0.11.1. Check the vendor advisory for mitigations.
References
- https://github.com/InternLM/lmdeploy/commit/eb04b4281c5784a5cff5ea639c8f96b33b3ae5ee
- https://github.com/InternLM/lmdeploy/security/advisories/GHSA-9pf3-7rrr-x5jh
- https://github.com/InternLM/lmdeploy/security/advisories/GHSA-9pf3-7rrr-x5jh
Get alerted when CVE-2025-67729 or the next vulnerability affects your stack